17:19 PM
reosarevok
yvanzo: ticket editing permissions seem too important to restrict IMO
17:19 PM
So I guess we need to live with users changing priorities
17:19 PM
Can we follow priority changes exclusively?
17:20 PM
akhilesh
Mr_Monkey: yes, thanks for resolving that issue.
17:21 PM
bitmap
Cyna: make sure req is being outputted by the sanitizedContext function, we went over this in another branch
17:23 PM
Cyna
I made some changes, removed the uses of $c in the file that is being hydrated
17:23 PM
Replaced by directly passing in params
17:24 PM
`TypeError: $data.selectionMessage is not a function` getting this in the console now
17:27 PM
reosarevok
bitmap, yvanzo: do you want to talk PRs then? :)
17:27 PM
bitmap
reosarevok, yvanzo: I'm around, just making coffee first
17:27 PM
sure :)
17:28 PM
yvanzo
17:29 PM
(there is no notification for field-level change)
17:34 PM
alastairp
aidanlw17: Cyna: please put your flight numbers on the wiki for the summit so we can coordinate arrival times
17:39 PM
Cyna
Well My flights haven't been booked yet, As the VISA process is still pending
17:42 PM
bitmap
17:43 PM
alastairp
Cyna: great, as soon as you know then :)
17:43 PM
bitmap
seems to have no conflicts, so should be in a good state. would it help to try doing the code review on irc?
17:44 PM
reosarevok
yvanzo: ^ :) (works fo rme)
17:44 PM
pristine__
alastairp: I need help in defining a config var name.
17:45 PM
bitmap
maybe asking "why is line x doing y" or "i'm not sure about z" here would be faster than back-and-forth on github
17:46 PM
pristine__
We have a date time value = x and we wish to move date in x to a particular date, something like, date.replace(days=y)
17:46 PM
What should be the name of y ?
17:46 PM
Y is a integer here.
17:46 PM
an*
17:47 PM
Rotab joined the channel
17:48 PM
yvanzo
bitmap, reosarevok: Rule added.
17:48 PM
bitmap has the branch checked out too
17:48 PM
yvanzo too
17:48 PM
Cyna
bitmap: `TypeError: $data.selectionMessage is not a function` what does this mean ?
17:49 PM
dependency issue ?
17:49 PM
I've ruled out that its a syntax error
17:49 PM
pristine__
ruaok can also help:)
17:50 PM
bitmap
Cyna: search for area_bubble root/components/forms.tt. it must not be applying the knockout bindings correctly ($data should be an area entity)
17:51 PM
yvanzo
bitmap, reosarevok: I actually started to review it today, shouldn’t be long to finish, can we jump to the next one?
17:51 PM
bitmap
okay
17:51 PM
17:51 PM
reosarevok
I'll quickly rebase
17:51 PM
Not that the conflict is very relevant, but
17:52 PM
bitmap
we haven't added any new NotFound pages since, I hope
17:52 PM
yvanzo
17:52 PM
BrainzBot
MBS-9911: Convert attributes admin templates to React/JSX
17:54 PM
bitmap
I guess it should be easy to see from components.js after you rebase
17:55 PM
reosarevok
bitmap: we added genre but IIRC I already updated it for that
17:55 PM
bitmap
okay, good
17:57 PM
reosarevok
Rebased, pushed
17:57 PM
yvanzo
I don’t really the added value of refactoring all NotFound in a single file, there is almost no code deduplication here, am I missing something?
17:58 PM
reosarevok
They're all the same concept, with mostly small variations on one string
17:58 PM
It makes much more sense to me for all of it to be together
17:59 PM
(if we decide to change something of how it works, we can change one file rather than 30)
17:59 PM
Cyna
yvanzo: done
18:00 PM
aidanlw17
alastairp: I’ll put mine up right now!
18:00 PM
reosarevok
Cyna: thanks! yvanzo: works nicely!
18:01 PM
bitmap
the NotFound pages all previously shared the same structure, so they had the same imports and markup, just the messages differed
18:01 PM
yvanzo
We could have the rule to automatically restore the previously set priority with an explanatory comment but I feel we should preferably review it.
18:01 PM
bitmap
so not much actual code/logic was duplicated, but a lot of boilerplate (imports/markup)
18:02 PM
alastairp
pristine__: can you pastebin the code with a bit more context?
18:02 PM
reosarevok
Yeah, I agree that if it's not crazy (and it shouldn't be) we should review it :)
18:03 PM
I suspect around half are just pointless changes, but half are relevant
18:04 PM
Cyna
bitmap: the bindings werent applied because I didnt add ```<!-- ko with: target() && target().area -->
18:04 PM
{...}
18:04 PM
<!-- /ko -->```
18:04 PM
Its strange adding something like this to React
18:04 PM
So I left it out
18:05 PM
Dont know how to make it work, cause it doesnt work directly
18:05 PM
yvanzo
Well, I don’t think it hurts.
18:05 PM
pristine__
18:05 PM
line 19
18:06 PM
reosarevok
yvanzo: the priority thing or the PR?
18:06 PM
pristine__
I don't think passing "1" is a good idea. I want to define this in config
18:06 PM
alastairp: ^
18:10 PM
ruaok: How have we configured the three workers. I don't understand it through the docker compose. On my local machine, I have one master container and one worker container as reflected in docker compose, and the same docker compose is used on leader, then how three worker containers?
18:10 PM
yvanzo
reosarevok: the PR
18:11 PM
aidanlw17
18:11 PM
reosarevok
yvanzo: ok, other than that is there something in the code to comment etc? :)
18:11 PM
aidanlw17: it's a wiki ;)
18:12 PM
aidanlw17
reosarevok: just dunno if it's ok for me to change the schedule? guessing that's a yes ;)
18:12 PM
reosarevok
If it's a clear error, sure
18:12 PM
(otherwise, suggest only maybe :) )
18:12 PM
yvanzo: I'll take that as a no :)
18:12 PM
aidanlw17
Ok, thanks!
18:12 PM
reosarevok
Oh, I saw the comment now
18:13 PM
yvanzo
reosarevok: sorry, approved on github already
18:13 PM
bitmap
nice, wanna do a couple more?
18:13 PM
reosarevok
Works for me
18:13 PM
I need hours this week anyway, I've been too lazy :p
18:13 PM
bitmap
18:14 PM
reosarevok
Oh! :)
18:14 PM
I guess the comment is a good one in that the variable is not very clearly named
18:14 PM
Will rebase + rename!
18:15 PM
bitmap
though with xByY naming I usually think it's an object where you can lookup an x using y as a key
18:15 PM
yvanzo
+ TODOs should probably be better named/placed to be meaningful outside of the PR.
18:16 PM
reosarevok
bitmap: any suggestions that make it more clear?
18:16 PM
bitmap
maybe tracksWith instead of tracksBy?
18:16 PM
reosarevok
Maybe :)
18:16 PM
yvanzo
+1
18:18 PM
bitmap
for TODO: RecordingT should have an optional artistCredit property
18:18 PM
prashanth041 joined the channel
18:19 PM
it makes it sound like we should change RecordingT, but it should only be optional through recordings
18:19 PM
I mean tracks, sorry
18:19 PM
as in track.recording should be something like RecordingWithOptionalArtistCreditT :)
18:21 PM
reosarevok
Is there a way to say "RecordingT, but with this one difference" without defining it all again
18:21 PM
?
18:21 PM
If there is, we could just change it now I guess
18:22 PM
bitmap
maybe $ReadOnly<{|...RecordingT, artistCredit?: ArtistCreditT|}> ?
18:22 PM
haven't tested it
18:23 PM
reosarevok
"Test" means "run flow, see if it screams", right? Can do
18:23 PM
bitmap
but I think later properties should override old ones in spreads like that
18:23 PM
reosarevok
No errors, so I guess it's fine
18:25 PM
For the other, is it enough to give " // TODO: cdtocs needs to be defined eventually: +cdtocs: $ReadOnlyArray<MediumCdTocT>" ? yvanzo?
18:25 PM
Or "TODO: still missing cdtocs: etc"?
18:25 PM
yvanzo
isn't it "recording" attribute rather than "RecordingT" here that should have optional "artistCredit"?
18:25 PM
(but that's better if you fixed it rather than keeping a TODO :)
18:25 PM
reosarevok
What's the difference? The recording attribute is a RecordingT, right? So it's "a RecordingT but with optional artistCredit
18:26 PM
bitmap
yup
18:26 PM
yvanzo
reosarevok: no worry, I was just typing about the comment while you were fixing the real issue.
18:26 PM
bitmap
the difference is just the wording, adding attribute would make it clear you're not talking about the type
18:26 PM
reosarevok
Oh!
18:26 PM
Gotcha
18:28 PM
bitmap
though I'm not sure my suggestion actually makes the property optional
18:29 PM
this seems to {+artistCredit?: ArtistCreditT} & RecordingT
18:30 PM
yvanzo
the other TODO wording is fine although I'm not sure it is necessary and correct (shouldn't cdtoc be optional in some case?)
18:31 PM
bitmap
I'm not sure they're always loaded, but we always output a cdtocs array in Medium::TO_JSON
18:32 PM
so it would just be an empty array if they're not loaded
18:32 PM
yvanzo
OK then!
18:34 PM
reosarevok
IS something like this better?
18:34 PM
yvanzo
Is there a way to check that JSON passed to the renderer matches flow types at run time?
18:34 PM
reosarevok
18:35 PM
bitmap
18:35 PM
yvanzo
reosarevok: please add 💿 💿 💿 ;)
18:36 PM
bitmap
$ReadOnlyArray<💿>
18:37 PM
reosarevok
Ok, more seriously, I'll push
18:38 PM
yvanzo
18:38 PM
BrainzBot
MBS-10298: Check flow type at run time
18:39 PM
bitmap
thx
18:39 PM
alastairp
pristine__: hmm, a few ideas here
18:40 PM
how many times do you use this method replace_days? if it's only to get the first of the month, then I'd name it something like get_first_of_this_month instead
18:40 PM
in the case that you have at the moment, `days` is ok
18:40 PM
however, in this case I wouldn't do it like this
18:41 PM
instead, I'd pass in the year/month to create_training_data_from_window
18:41 PM
yvanzo
18:41 PM
alastairp
this way you could theoretically calculate the data for any month
18:41 PM
prashanth041 has quit
18:42 PM
reosarevok
18:42 PM
alastairp
normally it's better to pass information like this (what month to act on) as an argument, and collect the data as close to the "user" as possible
18:42 PM
e.g. if it's called by a user or by cron, either pass in this information as an argument, or in the main function get the current month and then pass that into your function
18:43 PM
yvanzo
reosarevok: OK, thanks, would be nice to explain that we had both host and Referer in the commit message
18:44 PM
reosarevok
Can do, how would you word it?
18:44 PM
bitmap: ? :)
18:45 PM
bitmap
well, fixing the case allows us to access them consistently